Monday, 26 May 2014

Configuration

 Configuration


3Components of ODM
ODM-object classes(group of similar objects)
objects-(A single record in obj. class)
Descriptors(object info)

*ODM info is divided in 3 parts , it supports diskless
/dataless systems
-->/usr/lib/objrepos
contains predefined object classes
-->/usr/share/lib/objrepos
-->/etc/objrepos
Customized devices object classes

*ODM commands
when no option left then only try odm commands
if used falsely the system might crash

-->odmadd
Adds object to an object class.

-->odmchange
Changes specific objects in a specified object class.

-->odmcreate
Creates empty object classes

-->odmdelete
Removes objects from an object class

-->odmdrop
Removes an entire object class

-->odmget
Removes objects from object  classes

-->odmshow
Description of an object class

*Examples of using the ODM

+Device configuration
Predefined Devices (PdDv) contains entries for all devices that can be supported by AIX.
-->odmget -q "type like lv* " PdDv
To search all objects whose type start with letters lv

+Software vital product data
-->odmget lpp | head -30
To find from class lpp about all the s/w installed on the system & select 30 lines of output

+LVM
The odm maintains a copy of all data used by lvm, Commands that affect the lvm are designed so that data from VGDA's located on hard disks are always synchronized with info stored in odm
-->odmget -q name=hdisk0 CuAt

CuAt contains customized device specific attribute information
The command will find all attributes of hdisk0 from CuAt

*System Management Interface Tool
 SMIT runs in two modes
:ASCII(non-graphical)
:X-window(graphical)
ASCII--> smitty /smit -a
Graphical -->smit/smit -m

*System Management Tasks
1)Software Installation & Maintenance
-Installing new Software
-Updating software
-installing  fixes
-listing installed software
-backing up
-restoring the system image

2)Software License Management
-Adding & Deleting node-locked licenses
-Adding & Removing Server Licenses
-Listing Licenses

3)Devices
-Adding , changing, showing, deleting physical & logical devices
-Configuring & unconfiguring devices
-Listing installed devices
-Managing PCI hot plugs

4)System Storage Management (Physical & Logical Storage)
-Managing logical volumes
-Volume groups
-Physical disks
-Paging Space
-Managing file systems
-Managing files & Directories
-Backing up & Restoring the system

5)Security & USer
-Managing user accounts & groups, passwords, login controls, & roles

6)Communications Applications & Services
-Configuring all installed communications options & applications, including TCP/IP, NFS server or client,NIS,DNS.
7)Print Spooling
8)Problem Determination
-Running hardware diagnostic
-Performing system traces
-initiating system dumps
-Printing error logs
-Verifying software installation and requisites.

9)Performance & Resource Scheduling
-Scheduling jobs
-Managing resource processes
-Configuring & enabling power management
-Configuring & using the WLM
-Running System Trace
-Reporting System Activity

10)System Environments
-Starting & Stopping the system
-Configuring & Monitoring System Environment parameters such as long, date,user interface, time, managing system logs, managing the remote reboot  facitlity, managing system hang detection.

11)Processes & subsystems
-Managing subsystems, processes, subservers.

*Linux Applications in AIX
The AIX toolbox for linux applications CD that is shipped with your BOS contains the most commonly used open source applications that  you can use with aix os.

Your options for installing from this CD include
1)-->install_software
Install RPM packages from the AIX toolbox for linux application CD

2)-->geninstall

3)Installing a bundle
a)Installing RPM packages using SMIT
-->install_software
b)Install using the geninstall command
-->geninstall -d /dev/cd0 R:cdrecord R:mtools

*Install using the rpm command
To install the bundles required for the GNOME desktop and the bc application package from AIX toolbox for linux applications.
1)Insert the Aix toolbox cd in cd-rom
2)Mount the cd-rom
-->mount -vcdrfs -oro /dev/cd0 /mnt
-v specifies the virtual file system type of cdrfs.
-o ro option(mounted file is read only)

3)-->cd /mnt/ezinstall/ppc

4)Install GNOME by using  following commands
-->rpm -Uhv ezinstall/ppc/base/*
-->rpm -Uhv ezinstall/ppc/desktop.base/*
-->rpm -Uhv ezinstall/ppc/gnome.base/*
-->rpm -Uhv ezinstall/ppc/gnome.apps/*
-U updates any earlier versions of each package that you might have on your system.

If rpm command returns an error , it is probably caused by one of the following.
1)Not enough space in your current filesystem.
2)Package is already installed , with same level, version

A script on the cd installs only those packages from a directory that are not already installed on your system.

-->/mnt/contrib/installmissing.sh ezinstall/ppc/desktop.base/*

3)Failed dependencies
*Linux Applications which we have installed , to use them with commands and shells ,we must define PATH
-->print $PATH
/usr/bin:/etc/:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin

-->nl -?
-->export PATH=/usr/linux/bin:$PATH
-->print $PATH
/usr/linux/bin:/usr/bin:/etc:/usr/sbin:...

-->nl -?
Try '/usr/linux/bin/nl --help ' for more info

*Setting an alias
alias command = absolute path to command with options if any.

-->alias rm=/usr/linux/bin/rm

*Network File  System NFS
>NFS - distributed filesystem
>NFS - allows users to access files & directories
of remote servers as though they were local.
-You can use os commands to create , remove, read, write & set file attributes for remote files & directories
>NFS is independent of machine types, operating systems, & network architectures because of its use of remote procedure calls (RPC) for these services.

*For the successfull implementation of NFS you need following things
-NFS daemons should be running on the server and the clients
-The filesytems that need to be remotely available will have to be  exported.
-The exported file systems need to bo mounted on the remote (client)systems.

*NFS Services

Major Services provided by NFS are
+Mount -This service is provided by /usr/sbin/rpc.mountd daemon on server
& /usr/sbin/mount command on the client
The mountd daemon is a Remote Procedure Call (RPC)
that answers a client request to mount a filesystem. The mountd daemon provides a list  of currently mounted filesystems & the clients on which they are mounted.

+Remote file access - This service is provided by
/usr/sbin/nfsd daemon on server &
/usr/sbin/biod daemon on client
The biod daemon runs on all NFS client systems, when a user on an client wants to read or write to a file on a server, the biod daemon sends this request to the server.

*nfs daemons can be started using
-->smitty mknfs
-->mknfs -N

*-->startsrc -g nfs
start all of the NFS daemons
-->startnfs -s nfsd
start nfs daemon, individually

-->lssrc -g nfs
Verify that nfs is already running.

*Exporting NFS directories -using SMIT
1)-->lssrc -g nfs
biod
nfsd
rpc.mountd
rpc.statd
rpc.lockd
(all active)

smitty
-->smitty mknfsexp
-->exportfs -a
-->showmount -e server

command line
-->vi /etc/exports
-->/usr/sbin/exportfs -a

2)-->smitty mknfsexp
/etc/exports file will be updated

3) -->/usr/sbin/exportfs -a (server, send all information in the /etc/exports file to the kernel.

4)Verify that all file systems have been exported
-->showmount -e Myserver(server name)

*Exporting NFS directory using a text editor
-->vi /etc/exports
/home1
/home2
/home3

-->/usr/sbin/exportfs -a

*Exporting NFS directory temporarily
A file system can be exported when needed, & does not change the /etc/exports file
-->exportfs -i /dirname
The exportfs -i command specifies that the /etc/exports file is not to be checked for the specified directory, and all options are taken directly from the command line.

*Un-exporting an NFS directory
+Using SMIT
server -->smitty rmnfsexp
enter the name of directory in the PATHNAME of,exported directory to removed, field.
+Using text editor
1)-->vi /etc/exports
delete the line

2)If nfs is currently running 
-->exportfs -u dirname
where dirname is the full path namem of the directory, you just deleted from the /etc/exports file.

*Mounting an NFS directory
3 Types of mounts
a)Predefined
b)explicit
c)automatic

a. Predefined (by default) mounts are specified in the
/etc/filesystems
ex. NFS stanza in the /etc/filesystems file
/home1:
dev="/home1"
vfs=nfs
nodename=Myserver
mount=true
options=log,hard,intr
account=false


server start -->/etc/rc.nfs-->exportfs -->/etc/exports -->rpc.mountd,nfsd start

client-->/etc/rc.nfs -->biod -->mount command -->/etc/filesystemm -->binding

*NFS mounting process
When a client mounts a directory, it does not make a copy of that directory. Rather, the mounting process uses a series of remote procedure calls to enable a client to access the directories on the server transparently.
The following describes the mounting process.
1)When the server starts, /etc/rc.nfs script runs the exportfs command which reads the server /etc/exports file and then tells the kernel which directories are to be exported and which access restrictions they require

2)The rpc.mountd daemon & several nfsd daemons (8, by default) are then started by the /etc/rc.nfs script.

3)When the client starts, the /etc/rc.nfs script starts several biod daemons(8,bydefault), which forward client mount requests to the appropriate server.

4)Then  the /etc/rc.nfs script executes the mount command , which reads the file systems listed in the /etc/filesystem file.

5)The mount command locates one or more servers that export the information the client wants and sets up communication between itself & that server. This process is called binding.

6)The mount command then requests that one or more servers allow the client to access the directories in the client /etc/filesystems file.

7)The  server rpc.mountd daemon receives the client mount request. If the requested directory is available to that client, the rpc.mountd daemon sends the clients kernel an identifier called a file handle.

8)Client kernel then ties the file handle to the mount point.

*-/etc/rc.nfs runs exportfs
-nfsd, rpc.mountd started
-filehandle

/etc/rc.nfs
-biod starts

server binding client

*Establishing predefined NFS mounts
Mounts that are non-interruptible and running in the foreground can hang the client if the network or server is down when the client system starts up. If a client cannot access the network or server, the user must start the machine again in maintenance mode and edit the appropriate mount requests. So to avoid this situation, define the bg(background) and intr(interruptible) options in the /etc/filesystem file when establishing a predefined mount that is to be mounted during system startup.

To establish predefined mounts through SMIT client
-->smitty mknfsmnt
This method  creates an entry in the /etc/filesystems file for the desired mount and attempts the mount.

To establish the NFS default mounts by editing the /etc/filesystems file (use this method only under special circumstances)
1)-->vi /etc/filesystems
(client)
/home1:
dev=/home1    remote filesystem name
mount=false    NFS will be not mounted when the system boots
vfs=nfs
nodename=Myserver    machine on which the remote filesystem mounted
options=ro,soft
type=nfs_mount    [nfs_mount--the system attempts to mount  the /home1 filesystem like all defined in nfs_mount group]
(This stanza directs the system to mount the /home1 remote directory over the local mount point of the same name, FS mounted as ro, Due to the fact that it  is mounted as soft  an error is returned in the event the server does not respond.)

/home2
dev=/home2
mount=true
vfs=nfs
nodename=Myserver
options=ro,soft,bg
type=nfs_mount

2)save & close

3)-->mount -a
mount all directories specified in the /etc/filesystems.
The NFS directory is now ready to use.

*Mounting an NFS directory explicitly
1)-->showmount -e Myserver
/home1
/home2

Verify that the NFS server has exported the directory
2)-->smit mknfsmnt (client)
3)Complete the process, that's it.

*Mounting an NFS directory automatically(how it works)
automount command sends automatic mount configuration information to the AutoFS kernel extension and start the automountd daemon.
And due to only this the extension automatically and transparently mounts filesystems whenever a file or a directory within the file system is opened. The extension informs the automountd daemon of mount & unmount requests, & the automountd daemon actually performs the requested service.
Autofs allows the filesystems to be mounted as needed. With this method of mounting directories, all the filesystems do not need to be mounted all of the time, only those being used are mounted.
for ex. to mount the /backup NFS directory automatically.

1)Verify that the NFS server has exported the directory by entering
-->showmount -e Myserver
/backup

2)Create an Autofs map file. Autofs will mount & unmount the directories specified in this map file. An example of a map file can be found in /usr/sample/nfs

3)Ensure that the AutoFs kernel extension is loaded and the automounted daemon is running .
This can be accomplished in two ways.
a. Using SRC, enter
-->lssrc -s automountd
if is is not running, start it by
-->startsrc -s automountd
b.Using the automount command
Define the map file
-->/usr/sbin/automount -v /backup /tmp/mount.map
where /backup is the AutoFS mountpoint on the client . Now if a user runs the
-->cd /backup
the AutoFS kernel extension will call the automountd daemon, which will mount the /backup directory & then allow the cd command to complete.

4)To stop the automountd
-->stopsrc -s automountd

*Changing an exported filesystem
This section explains how you can change an exported NFS.
a)Changing an exported NFS directory using SMIT
1)Un-export the filesystem on the server by entering
-->exportfs -u /dirname
/dirname is the name of the filesystem you want to change.

2)On the server
-->smitty chnfsexp
make changes

3)Reexport the filesystem
-->exportfs /dirname

b)Changing an exported NFS directory using a text editor
1)Unexport the filesystem
-->exportfs -u /dirname
2)--> vi /etc/exports
3)Make Changes
4)Reexport
-->exportfs /dirname

*Unmounting a mounted Filesystem
-->umount /directory


1)Start nfs daemon
-->smitty mknfs
-->mknfs -N
-->startsrc -g nfs
-->stratsrc -nfsd

2)Verify that NFS is already running
-->lssrc -g nfs

3)Exporting NFS directories using SMIT
-->smitty mknfsexp
-->exportfs -a
-->showmount -e servername

4)Exporting NFS directory using  command line
-->vi /etc/exports
-->/usr/sbin/exportfs -a

5)Un-exporting an NFS directory using smit
-->smitty rmnfsexp (server)

6)Unexport NFS dir using text editor
--> vi /etc/exports
-->exportfs -u /dirname(which we have deleted from /etc/exports )

7)3 types of mounts
1)Predefined
client -->/etc/filesystem
/home:
dev=/home
vfs=nfs
nodename=ServerName
mount=true
options=bg, hard, intr
account=false

-->smitty mknfsmnt
this will create above entries in /etc/filesystems

2)explicity
-->smit mknfsmnt
completes the process

3)Automatically
-->lssrc -s automountd
-->startsrc -s automountd
-->/usr/sbin/automount -v /dirname /tmp/mount.map
-->stopsrc -s automountd
stop automountd

4)Default NFS mounts
-->vi /etc/filesystems (enter below stanza in this file)
/dirname:
dev=/dirname
mount=true/false
vfs=nfs
nodename=Servername
options=ro/soft/hard/intr/bg
type=nfs_mount

-->mount -a

8)Changing an exported filesystem /dir using SMIT
-->exportfs -u /dirname
unexport

-->smitty chnfsexp
-->exportfs /dirname

9)Network Configuration
Do not restart TCP/IP daemons, using the command
-->startsrc -g tcpip
It will start all subsystems defined in the ODM for the tcpip group, which includes both routed & gated.

*rc.tcpip
If file does not activated during boot then most daemons will not start. We can telnet, ftp to others but the cannot to us. But  others can ping us.
-->telnet host
Remote host refuse connect operation

-->ftp host
Remote host  refuse connect  operation.

10)inted daemon
/usr/sbin/inted daemon provides internet service  management for a network. This daemon invokes other daemons when they are needed.

*Starting and refreshing inted
+If you change the /etc/inted.conf using  SMIT, then the inted daemon will be refreshed automatically , & will read the new /etc/inted.conf file.
+If you change the file using an editor,
run
-->refresh -s inetd
or
-->kill -1 intedPID
this will refresh it.

*Subservers controlled by inted
ftpd,rlogind,rexecd, rshd, talkd, telnetd, uucpd -Started by default

tftpd, fingerd, comsat - not started by default

*Check details of subservers
-->lssrc -ls inetd

*/etc/services
This file contain information about the known services used in the internet network by inted,
If you edit the /etc/services file run .
-->refresh -s inted

*Stopping inted
-->stopsrc -s inted
When the inetd daemon is stopped, the previously started subserver processes are not affected. But new subserver can not be started.

*To check attributes of any interface
-->inconfig lo0
-->lsattr -El lo0

*Portmap
converts RPC in port numbers.
when RPC server starts then it tells the portmap daemon that on which it is accessible, then the portmapper saves that portnumber(which access RPC server). That's why portmapper has all ports of all programs
When client has to access any application then it ask the portmap the port number of that application.
RPC daemon is start before inetd so portmap is also start before inetd.

If Portmap stop/restart then RPC server should be restarted.
-nfsd is a common RPC server

*Loopback interface allows a client & server on the same host to communicate with each other using TCP/IP
-->ifconfig lo0
-->lsattr -El lo0

*Network address is an IP address with all host address set to 0.
-->netstat -nr

*255.255.255.255 - Limited broadcast address.
An address with all host address and network address bits set to 1. This is used as the destination address for all hosts regardless of their network number.
Routers never forward a limited broadcast, it only appears on the local cable.

*The directd broadcast address is an IP address, with all the host address bits set to 1.
It is used to simultaneously address all hosts within the same netwrok.
ex. 195.116.192.2 -C
195.116.192-Network address
so the directd broadcast for this network will be 195.116.192.255
-->ifconfig en0

*Gateways or routes are systems or network devices that will route information onto other systems or networks.

*The default order in resolving hostnames is
1)BIND/DNS (using /etc/resolv.conf)
2)NIS
3)/etc/hosts file.

When a process receives a sysmbolic hostname and needs to resolv it into an address, it call a resolver routine.
The default order can be overwritten by creating the configuration file, /etc/netsvc.conf
and specifying the desired order.
-->/etc/netsvc.conf
hosts=nis,local,bind(as you like it)

*Both the default and /etc/netsvc.conf can be overwritten with the variable NSORDER
-->export NSORDER=bind,nis,local

*The NSORDER environment variable will override the host name resolution list  in /etc/netsvc.conf
If your /etc/netsvc.conf does work properly the check NSORDER variable
-->echo #NSORDER

*/etc/hosts
This file provides a list of server names or aliases and their IP address.
IP Address     Hostname

*/etc/resolv.conf
-->vi /etc/resolv.conf
nameserver 9.31.4
domain itsc.austin.ibm.com (what domain it belongs)

*Troubleshooting resolving a host.
1. Check /etc/resolv.conf
check nameserver IP
check domain-name
2. ping server
3. check nameserver
4. check logs in /etc/syslog.conf

*Adding network routes
-->smit mkroute
to add a route to the private network through the gateway between two networks.
Destination Type -net
Destination Address- 192.168.1
Default gateway Address- 9.3.1.4

-->route add -net 192.168.1(network) -netmask 255.255.255.0 9.3.1.4(gateway)

-->traceroute IP

*Change IP address
If you are moving your machine from one network segment to another, and need to change IP address.
-->smit mktcpip
HOSTNAME
IP
NETMASK
NETWORK INTERFACE
NAMESERVER
IP
DOMAIN NAME
DEFAULT GATEWAY

Do not perform this task in a telnet command session, as you will lose your  connection when the change is made, (you can do it in ssh, but beware to change the ip)

*ifconfig
Identifying network interfaces
-->lsdev -Cc if
or
-->ifconfig -a

*Activating NIC
-->ifconfig tr0 up
-->ifconfig lo0 127.0.0.1
-->inconfig tr0 10.1.2.3 netmask 255.255.255.0 up

*Deactivating NIC
-->ifconfig tr0 down

*Deleting NIC
-->ifconfig tr0 delete

*Detaching a network interface
To remove an interface from the network interface list, the interface must be detached from the system. This command is used when a network interface card has physically been removed from a system or when an interface no longer needs to be defined within the system.
-->ifconfig interface detach
-->infonfig tr0 detach

This command removes all network addresses resigned to the interface & removes the interface from the output of the ifconfig -a command.
To add an interface back to  the system, or to add a new interface to the network interface list
-->ifconfig interface (the interface u want to add)

*Creating an IP alias for a network interface
-->ifconfig interface address[netmask Netmask ] alias

-->ifconfig tr0 10.1.2.3 netmask 255.255.255.0 alias IP address
There will be no ODM record created of the alias by this command, You need to invoke the same commad every time you reboot your system to preserve the alias. If your system configuration has a local startup script defined in the /etc/inittab file.
This command should be included in that local script

-->ifconfig -a -d
show only those interfaces that are down.

*Delete alias
-->ifconfig tr0 10.1.2.3 netmask 255.255.255.0 delete
specify exactly which alias you want to be removed, system will default remove primary network address, then the first alias in the list of network addresses become the primary network address. To remove all aliases from and interface , you must delete each alias individually.

*Changing the MTU size of a network interface
By default, a 16MB token-ring interface will transmit packets that are 1492 bytes long,
Ethernet packets- 1500 bytes long

*Determine MTU size for a network interface
-->lsattr -El interface
-->lsattr -El en0

*Change the MTU size
-->ifconfig en0 mtu 2000

*All systems that are on the same LAN must have the same MTU size, so when to change MTU you must simultaneously chage all nodes MTU.
stop interface and then change.

*The ntp.conf
ntp.conf file controls how network time protocol(ntp)daemon xntpd operates and behaves

*Truseted daemons
-ftpd
-rexecd
-telnetd

*non-trusted
-rshd
-rlogind
-tftpd

*$HOME/.netrc
info used by automatic logic feature of the rexec and ftp commands.
-logic password
-file permission must be 600
entries in the $HOME/.netrc file are like below.
>machine hostname- name of remote host and all other parameters of host

>login UserName-FQDN
>password
>account password
>macdef

*/etc/hosts.equiv
/etc/hosts.equiv along with any local $HOME/.rhosts files, defines the hosts and user accounts that can invoke remote commands on a local host without supplying a password.
A user or host that is not required to supply a password is considered trusted, though the daemons that initiate the connections may be non-trusted in nature(ex. rlogind).
When a loacal host receives a remote command requests, the appropriate local daemon first checks the /etc/hosts.equiv file to determine if the request originates with a trusted user or host.
ex. If the local host receives a remote login request, the rlogind daemon checks for the existence  of a hosts.equiv file on the local host. If the file exists, but does not define the host or user, the system checks the apppropriate $HOME/.rhosts file.
This file is similar to the /etc/hosts.equiv file except that it is maintained for individual users.
If a remote command request is made by the root user, the /etc/hosts.equiv file is ignored & only the /.rhosts file is read.

*Format of the /etc/hosts.equiv & $HOME/.rhosts file as follows
eg. To allow all the users on the hosts idea and vodafone to log in to the local host,enter
idea
vodafone

eg. To only allow the user bob to log in from the host vodafone , enter
idea
vodafone bob

eg. To allow all users from the host idea to log in , while requesting users joey and ross for a password to log in
vodafone
idea-joey
idea-ross
idea

eg. To deny all members of the forum netgroup(NIS)
from logging in automatically ,enter
-@forum

*Operations on a network adapter
1)Adding a network adapter
You should perform this procedure during a system maintenance window, as this procedure will require the shutdown of the system and may interfere with the work of users on the system.
i)examine what network adapters and interfaces are already on the system by
-->lscfg | grep -i adapter
-->lsdev -Cc if

ii)shut down & power off the system for systems without hot plug cards.

iii)Physically install the new network adapter

iv)Poweron the system in normal mode.

v)When the system is fully up, run the cfgmgr command, This will automatically detect the network adapter and add network interfaces for the adapter

vi)-->cfgmgr

vii)Confirm the network adapter has been properly added to the system
-->lscfg | grep -i adapter
-->lsdev -Cc if

* Removing a network adapter
Do this in System maintenance window because you may need to restart the system.

i)Deactivate all network interface definitions for the network adapter by running
-->ifconfig interface down

ii)Remove (detach)all network interface definitions from the network interface list
-->ifconfig interface detach
This will remove all attributes associated with the network interface from the system, including attributes like IP address & MTU size.

iii)Delete the network interface definitons
-->rmdev -l interface -d

iv)Delete the network adapter definitions
-->rmdev -l adapter -d

v)shutdown, remove the adapter

vi)poweron

*Adapter and interface configuration problems
1)MEdia speed configuration problems
An incorrect media speed will prevent the system from communicating with other systems or networks.
>Sysmptoms of a problem due to incorrect media speed
i)-Connection timeouts(telnet)
ii)-No packet transmission or response(ping)
iii)-Unusual pauses & hangs when initializing communication daemons(inetd)

To correct media speed problems
i)Obtain proper media speed from your network admin.

ii)Remove / detach all network interfaces for the network adapter
-->ifconnfig interface detach
Removing all network interface by detach will remove all configuration, for network interface  , keep a copy of all necessary configuration, for network interfaces for reconfiguration

iii)To change the media speed for an ethernet adapter
-->smitty chgenet

*Cable type configuration problems
Ethernet adapters can use different types of cable connections, bnc, dix or tp
If the cable type is set incorrectly, the system may not be able to communicate properly.
To set the cable tyep
-->smitty tcpip

*Paging Space
A page is a unit of virtual memory size = 4 kB
Paging space also called a swap space
-Paging space can use no less than 64MB
-1.5 X RAM / 2 X RAM
when p.s. gets low fork operations failed.

Tips
-1 ps on 1 pv
-PS shouldnt be on Heavily active disk/lv
-Every ps should be of same size
-Do not spread 1 ps on many pv's
-Allocate ps on pv's which attached to differnet disk controllers.

*Managin ps
>Displaying ps usage
-->lsps -a

>Increase the size of hd6 with 3LP
-->chps -s 3 hd6

>Reducing ps of hd6 with 1LP
-->chps -d 1 hd6

*Moving the hd6 ps to another vg
Not recommended

*Moving a ps within the same vg
Moving a ps including hd6 from the default location to different disk within the same vg does not require system reboot
-->migratepv -l hd6 hdisk0 hdisk1
Move the default ps from hdisk0 hdisk1

*Removing ps (not hd6)
First deactivate the ps
-->swapoff devicename
-->swapoff /dev/paging03
to deactivate ps paging03

-->rmps paging03
To remove paging03

*Device Configurations
>Determining the existing device configurations
1)lscfg
To display summary or detailed data about devices, vital product data, part numbers,serial numbers, engineering change levels from either the cutomized VPD object class or platform specific areas. Not all device contain VPD data.
-->lscfg -v -p -l rmt0
Display the  VPD for about rmt0

-->lscfg -v -p -l ent2
Obtain the physical location and firmware version of eth0

2)lsdev
Display information about devices in the device configuration database
-->lsdev -C -c disk
Show the disk drives on your system

-->lsdev -C -c tape
Show the tape devices on your system

-->lsdev -C -c adapter
Show all the adapters on your system

3)lsattr
Display attributes of a given device or kind of device.
i)To learn more about a particular processor,
-->lsattr -El proc0

ii)To discover how much memory is installed
-->lsattr -El sys0 | grep realmem

iii)To discover if ent2 supports jumbo frames transmission
-->lsattr -EHl ent0 -a jumbo-frames

iv)To discover if device driver software for the 14100401 class of adapters(gigabit Ethernet) is installed
-->lslpp -l | grep 1410041

*Remove a device configuration.
To unload an existing device from the system, you have two possibilites ; either change the state from AVAILABLE to DEFINED or permanently delete all entries from the ODM
Following example show the process to change the state
-->lsdev -Cc tape
rmt0 Available 09-87-.....

-->rmdev -l rmt0
rmt0 Defined

-->lsdev -Cc tape
rmt0 Defined

To unload the device configuration from the ODM
use -d option
-->rmdev -dl rmt0
rmt0 deleted

-->lsdev -Cc tape
rmt0 is completely removed

-->cfgmgr
-->lsdev -Cc tape
rmt0 Available

*Modify an existing device configuration

i)To change one or more attributes of the tok0 token-ring adapter to preset values as described in the changattr file
-->chdev -l tok0 -f changattr
tok0 changed

ii)To change the SCSI ID of the available scsi0 SCSI adapter that cannot be changed(mode unavailable due to available disk drives connected to it)
-->chdev -l scsi0 -a id=6 -P
scsi0 changed

iii)Move the defined tty11 TTY device to port 0 on the sa5 serial adapter
-->chdev -l tty11 -p sa5 -w 0
tty11 changed

iv)To change the maximum number of porcesses allowed per user to 100,
-->chdev -l sys0 -a maxuproc=100
sys0 changed

v)-->lsattr -El rmt0
detailed output

vi)Change the block size parameter
-->chdev -l rmt0 -a bloc_size=512
rmt0 changed

*SMIT fast  paths for device configuration
-->smitty devices
-->smitty chdev
-->smitty rmdev

*Special device configurations
i)To turn off simultaneously multithreading  immeadiately, without rebootinng
-->smtctl -m off -w now

-->bindprocessor -q
query the available processors.

ii)Turnon simultaneously multithreading after the next reboot
-->smtctl -m on -w boot
-->bootinfo -y
Type of system hardware you have 32 bit or 64 bit.
If result is 32 you cannot use 64-bit kernel after system installation , you will need to instruct the system to use the 64-bit kernel information stored on the /usr/lib/boot/

2.Two kernels are available in /usr/lib/boot/
unix-mp 32 bit kernel for multiprocessor systems
unix-64 64 bit kernel for multiprocessor systems

To enable the 64 bit kernel after system installation
-->ln -sf /usr/lib/boot/unix_64 /unix
-->ln -sf /usr/lib/boot/unix_64/ /usr/lib/boot/unix
-->bosboot -ad /dev/ipldevice
-->shutdown -r
After the system has rebooted , it will be running the 64-bit kernel. To reactivate the 32-bit kernel , follow the same procedure, substituting unix_mp for unix_64 depending on your system tape.
To verify your settings
-->ls -al /unix

No comments: