Booting involves the following steps
1)Post (verify that the basic h/w is in functional state. Memory, keyboard,communication , audio devices ,storage are initialized)
2)Press a key and choose a boot device.
3)System Read only Storage (ROS) will locate & load bootstrap code(s/w ROS)
4)S/W ROS (bootstrap code) forms an IPL control block,which takes control and builds AIX specific boot information.
5)A special filesystem is located in memory which is RAMFS filesystem.
6)Software ROS is AIX information based on machine type and it is responsible for completing machine preparation to enable it to start the AIX kernel
7)A complete list of files that are part of the BLV are in /usr/lib/boot directory.
-AIX kernel
-Boot commands called during the boot process,such as bootinfo & cfgmgr.
-Many devices need to be configured before hd4
is made available , so their corresponding methods have to be stored in the BLV, These devices are marked as base in PdDv.
-The rc.boot script(/sbin/rc.boot)
8)AIX kernel is loaded and takes control
LED-0299
The kernel will complete the boot process by configuring devices and starting the init process.
9)So far the system has tested the hardware, found a BLV, created the RAMFS, & started the init process from the BLV.
The rootvg has not been activated yet.
From now on , the rc.boot script will be called three times , & is passed a different parameter each time.
*Boot Phase 1
During this phase , followinng steps are taken,
1)The init process started from RAMFS executes the boot script rc.boot1
c06-fails(if)
2)At this stage, the restbase command is called to copy a partial image of ODM from the BLV into the RAMFS.
510-successfull
548-Not successfull
3)At this stage -->cfgmgr -f command configures Base devices that are necessary to access rootvg.
[for ex.,if the rootvg is located on a hard disk,all devices starting from the mohterboard up to the disk will have to be initialized.]
4)At the end of boot phase1, the bootinfo -b command is called to determine the last boot device -511.
*Boot Phase 2
In boot phase 2, the rc.boot script is passed to the parameter 2.
During this phase following steps are taken.
1)rootvg volume group is varied on with the command
-->ipl_varyon
517-successfull
552-554-556 UNSUCCESSFULL
2)-->fsck -f
Verify whether hd4 filesystem unmounted cleanly before the last shutdown.
555-not successfull
3)Mount the root file system(/dev/hd4) is mounted on a temporary mount point (/mnt) is RAMFS
-->mount /dev/hd4 /mnt
557-unsuccessfull.
4)-->fsck -f /var
5)-->fsck -f /usr
6)Paging space /dev/hd6 activated
7)mergedev process copies all /dev files from the RAMFS to disk.
8)Customized ODM files from the RAMFS are copied to disk. Both ODM versions from hd4 & hd5 are synchronized.
9)root fs, var, usr mounted
10)There is no console available at this stage , so all boot messages will be copied to alog.
The alog command maintains and manages logs.
-->alog -o -f bosinst.log
-->smit alog_show
*Boot Phase 3
Now rootvg is activated and following steps are taken.
1)/etc/init process is started . It reads the /etc/inittab file and calls rc.boot with argument 3.
2)The /tmp file system is mounted.
3)-->syncvg
to synchronize rootvg
553-successfull
4)-->cfgmgr -p3 (if system is booted in service mode)
-->cfgmgr -p2 (if system is booted in normal mode)
5)-->cfgcon
To configure the console. After configuration of the console boot messages are sent to the console.
All missed messages found in
-->/var/adm/ras/conslog
6)Synchronized of the ODM in the BLV with the ODM from the /(root) filesystem is done by the savebase command
-->savebase
7)syncd daemon & errdemon are started.
8) LED display is turned off
9)If /etc/nologin exists, it will be removed,
10)Execution of rc.boot has completed.
*System Initialization
During system startup, following sequence of events occurs.
1)init command is run as the last step of the startup process.
2)init command attempts to read the /etc/inittab file,
and try to locate an initdefault entry.
-if initdefault entry exists, the init command uses the specified run level as the initial system run level.
-if initdefault entry does not exist, the init command requests a run level from user.
-if user tyeps S,s,M,m runlevel, init command enters the maintenance run level. These runlevels do not require properly formatted /etc/inittab file.
3)If the /etc/inittab file does not exist, the init command places the system in the maintenace runlevel by default.
4)The init command rereads the /etc/inittab file every 60 seconds.
*/etc/inittab file
/etc/inittab control initialization process.
The /etc/inittab file is composed of entries that are position-dependent and have the following format:
Identifier:Runlevel:Action:Command(A shell command to execute)
Runlevel 0-halt
1-Single/Maintenace Mode
2-Multiuserr Mode
3 to 9 -Customized Mode
current runlevel
-->cat /etc/.init.state
Action: Tells the init command how to treat the process specified in the process field, The following actions are recognized by the init command.
--respawn- Restart always, start the process if it does not exist.
--wait-wait for the termination of process.
--once-when the init command enters a runlevel that matches the entry's runlevel, start the process, & do not wait for its termination, when it dies, do not restart it.
--boot-Process the entry only during system boot.
start it & then
dont care about it
let it run or die.
-->telinit -q
Rescans the inittab file to take effect the changes.
*Handling /etc/inittab file ,No flat file editing in AIX
-->mkitab
Adds records to the /etc/inittab file.
-->lsitab
Lists records in the /etc/inittab file.
-->chitab
Chages records in the /etc/inittab file.
-->rmitab
Removes records from the /etc/inittab file.
for ex. you want to add a record on the /etc/inittab file to run the find command in the runlevel 2 and start it again once it has finished.
ex.
1)Add a record named xcmd on the /etc/inittab using the mkitab command
-->mkitab "xcmd:2:respawn:find / -type f > /dev/null 2>&1"
2)lsitab xcmd
xcmd:2:respawn:find / -type f > /dev/null 2>&1
3)-->ps -ef| grep find
root 25462 - -- -
4)-->kill 25462
5)--> ps -ef | grep find
ro- - - -find / -type f
The process will continue respawning
-->rmitab xcmd
to delete xcmd record from /etc/inittab
-->cat /etc/inittab
*Order of the /etc/inittab entries-SRC has to be started near the begining of the /etc/inittab file since the SRC daemon is needed to start other processes. NFS requires TCP/IP daemons to run correctly, TCP/IP daemons started ahead of NFS daemons. Entries in /etc/inittab file are ordered according to dependencies , meaning that if a process(process2)
requires that another process(process 1) be present for it to operate normally , then an entry for process1 comes before an entry for process2 in the /etc/inittab file.
1)initdefault
2)sysinit
3)Powerfailure Detection(powerfail)
4)Multiuser check (rc)
5)/etc/Firstboot(fbcheck)
6)System Resource Controller (srcmstr)
7)start TCP/IP daemon
8)Start NFS daemons(rcnfs)
9)cron
10)pb cleanup
11)getty for the console(cons)
*How to recover from a non-responsive boot process
The bootlist command displays and alters the list of boot devices available to the system.
+Normal bootlist- The normal list shows the possible boot devices for the system when it is booted in normal mode.
+Service bootlist-List of possible devices when the system is booted in service mode.
+Previous boot device-Last device form which the sytem booted.
1)-->bootlist -m normal -o
Display a bootlist
-cd0, hdisk0 blv=hd5, rmt0
2)If you want to make changes to your normal bootlist and remove for ex. rmt0 use command
-->bootlist -m normal cd0 hdisk0
or
create a file containing the list of cd0 hdisk0(one device per line, or separeated by space)
-->bootlist -m normal -f filename
3)After changing the bootlist, verify the bootlist as follows
--> bootlist -m normal -o
Accessing a system that will not boot
If you are not able to boot the system, first you have to access it,
+Turn on all attached external devices, terminals, cd-rom, dvd-ram, tape drives,monitors,external disk drives before turning on the system unit . Turn on the system unit to allow the installation media to be loaded, means if system is not booting then first connect to it ,access it ,turn on ,installation cd1 in cd drive, restart then start maintenance mode for system recovery-Access a root vg- access a volume group start a shell b4 mounting filesystem
then take appropriate measures to recover data or take action to enable the system to boot normally,
*Common boot LED codes & soltions
1)LED 201 -Damaged Boot image
a) Access your rootvg from the maintenance mode
b) Check /, & /tmp filesystem size
c)Determine the boot disk by using
-->lslv -m hd5
d)Recreate the boot image using
-->bosboot -a -d /dev/hdiskn
where n is the number of the disk containing the BLV
e)Check for CHECKSTOP errors in errorlog.
These error indicates failing hardware
f)restart
2)LED 223-229 Invalid bootlist
if system is not booting then to do login go in maintenacne mode
3)LED 551,555,&557 Corrupted file system,corrupted jfs log.
a)Maintenance Mode-choice 2- Access the rootvg before mounting any filesystem
b)verify & correct filesystems (first unmount & then check)
-->fsck -y /dev/hd1
-->fsck -y /dev/hd2,3,4,9
c)Format the jfs log again using
-->/usr/sbin/logform /dev/hd8
d)Use
-->lslv -m hd5
disk on which hd5 is present
e)Recreate the boot image
-->bosboot -a -d /dev/hdiskn
4)LED 552,554,556
Superblock corrupted & corrupted customized ODM database
a)Maintenance mode
b)check all filesystem
c)If fsck indicates that block 8 is corrupted, the superblock for the filesystem is corrupted and needs to be repaired
-->dd count=1 bs=4k skip=31 seek=1 if=/dev/hdn of=/dev/hdn
d)Rebuild JFS log
-->/usr/sbin/logform /dev/hd8
If this solves the problem then stop here,otherwise continue with below steps
e)Your ODM database is corrupted. Restart system, go to maintenance mode, select choice 2 (access rootvg before mounting any filesystem)
f)Mount the root & user fs
-->mount /dev/hd4 /mnt
-->mount /usr
g)copy the system configuration to a backup directory
-->mkdir /mnt/etc/objrepos/backup
-->cp /mnt/etc/objrepos/Cu* /mnt/etc/objrepos/backup
h)copy the configuration from the RAM file system
-->cp /etc/objrepos/Cu* /mnt/etc/objrepos
-->umount all
j)-->lslv -m hd5
k)save the clean ODM to the boot logical volume by using
-->savebase -d /dev/hdiskn(disk containing BLV)
l)reboot
m)if problem persistes , reinstall the BOS
5)Filesystem issue- df ,/var,/tmp, /usr
hd5(BLV) bootlist -m normal -o
bosboot -a -d /dev/hdiskn
lslv -m hd5
fsck -y /dev/hd1,2,3,4,9
bootissue- bootlist,bosboot, lslv -m hd5
/etc/inittab--> df /,/var,/usr, /tmp
6)LED 553 Corrupted /etc/inittab file
a)Go to maint. mode
b)check space in /, /var,/tmp using df
c)check /etc/inittab file correct any problems
d)check problems with
/etc/environment file basic environment for processes.
/bin/sh
/bin/bsh
/etc/fsck
/etc/profile
/.profile
e)restart
*Runlevel
-->cat /etc/.init.state
*Displaing a history of previous runlevels
1)Log in as the root user
-->/usr/lib/acct/fwtmp < /var/adm/wtmp | grep run-level
*Changing system runlevels
-->lsitab init
to check the default runlevel
To change the run level check first that getty is enabled at all runlevels.
because getty enables all the terminal access possible.
Use the wall command to inform users
-->wall message
-->telinit M
change runlevel to maintenance level
*telinit command
telinit directs the action of init process , it sets the system at a specific runlevel.
-->telinit 0-9/S,s,m,M/a,b,c/Q,q/N
-->telinit M
To enter in maintenance mode
-->shutdown -m
*An introduction to the rc* files
1)rc.boot script called by init, it controls the machine boot process. It varyon rootvg, enable filesystems
-->/sbin/rc.boot file
2)/etc/rc file varyon all vgs marked as auto-varyon. Activate all paging spaces listed on /etc/swapspaces
Configure all dump devices
perform filesystem checks
mount filesystem
installation specific
3)/etc/rc.net
file that contains network configuration information . It allows you to enable the network interfaces & see the hostname,default gateway, static routes for the current host.
This script also be run to configure new devices that have been added to the system since boot time.
4)/etc/rc.tcpip
Automatically executed, uses SRC commands to initialize selected daemons. Most daemons that can be initialized by rc.tcpip are specific to TCP/IP
-inetd (started by default)
-gated
-routed
-named
-timed
-rwhod
*Dont run gated & routed at the same time on a host
other daemons specific to bos or other appliation that can be started through rc.tcpip
-lpd
-portmap
-sendmail
-syslogd(started by default)
-->stopsrc -s daemon
-->startsrc -s daemon
No comments:
Post a Comment